XP i IIS
Prikazujem rezultate 1 do 3 od 3

Tema: XP i IIS

  1. #1
    Iskusan codemaker (avatar)
    Učlanjen
    05.04.2004.
    Lokacija
    Beograd
    Poruke
    6.416
    Reputaciona moć
    0

    Podrazumevano XP i IIS

    Ok, znam, saveti da procitam Help mi ne ginu, ali citah sve sto sam mislio da moze da pomogne ali eto, treba mi pomoc:

    Posle dugog natezanja sa samim sobom, instalisao sam na jedan od racunara XP Professional. Posto izmedju ostalog radim i web prezentacije sa CGI, do sada sam uradjeno testirao na Win98 koristeci PWS (personal Web Server), bez problema

    E sad, u XP toga nema ali ima IIS.
    Instalisao kako sam umeo, ima dosta logicke slicnosti sa PWS ali mi se desava da moze da ucita samo prvu stranicu, koja je zapravo HTML tipa. Iz te stranice i sve naredne su EXE (ili DLL u Win98) koji zatim generisu stranice, citajuci iz baza podataka i isporucuju stranice sa rezultatima korisniku.
    Web site bi trebao da je dobro setovan, jer mogu preko mreze da pozovem na primer "http://10.4.0.1 pa se otvara strana na XP kompjuteru, ali dalje ni makac.

    Nakon prijave sa prve HTM stranice, IIS nece da startuje prvi EXE. Ne desava se nista. Ako direktno pozovem taj EXE iz browsera "http:/localhost/Chkvisit.EXE" dobijam stranicu da nemam prava da otovorim tu stranicu. Savet je da podesim "access rights" i tako to, gomilu saveta i uputa, kada kliknem na help.

    Posto mi je to prvi susret sa definisanjem "policies" u XP, nemam pojma sta, gde i kako. Svi folderi za koje sam mislio da treba su "shared" i "web shared", svi folderi unutar web site su shared i imaju prava za izvrsavanje, pregled i izmenu itd...
    Prema setovanju u PWS sam pokusao te atribute da podesim, ali ipak nece da otvori EXE koji je na drugom folderu od glavnog , startnog HTM..

    Jel' ima neko da mi malo pomogne? PWS u Win98 odlicno odradjuje posao, ali na XP ne mogu da testiram rad
    Sva sreca te nisam na svim kompjuterima kuci instalisao XP, sada bih se debelo zaglavio.

    Moj problem mislim da ima neke veze sa "FronPage extensions" ali nisam uopste siguran.

    Ako sa drugog racunara, preko mreze u browseru ukuam "http:/10.4.0.1" otvara se prva stranica na XP racunaru, ali nakon unosa lozinke, ne desava se nista takodje.

    Prvi puta koristim XP, i zato sam potpuno zaglavio sa svim tim podesavanjima ...



  2. #2
    Primećen član
    Učlanjen
    08.09.2003.
    Pol
    muški
    Lokacija
    Beograd
    Poruke
    869
    Reputaciona moć
    61

    Podrazumevano

    Ako sam te uopste razumeo, a mislim da nisam treba da podignes serverski dodatak na masini da bi ti bilo sta tog tipa radilo.

  3. #3
    Iskusan codemaker (avatar)
    Učlanjen
    05.04.2004.
    Lokacija
    Beograd
    Poruke
    6.416
    Reputaciona moć
    0

    Podrazumevano

    Citat Original postavio Hackers
    Ako sam te uopste razumeo, a mislim da nisam treba da podignes serverski dodatak na masini da bi ti bilo sta tog tipa radilo.
    Da, jednostavno receno, kompletan sajt mogu u Win98 da testiram pomocu PWS. Sta god da napravim.
    Na XP masini, nece da startuje EXE fajlove, koji generisu dalje HTM nakon "trkeljisanja" baze podataka.

    Instalisan IIS i svi direktorijumi podeseni, sve na svom mestu. Na Win98 otvara sve strane i salje/prima zahteve, na XP samo prvu stranu, sve dalje su zapravo EXE, nece.

    Konkretno, pocetna strana sajta je "webpay.HTM"
    Kada s u toj strani unese Username i Password, treba da se startuje Chkvisit.EXE itd...
    To radi sa PWS ok, na XP imam problem.

    Da nije IIS podignut, ne bi na adresi na primer "http://localhost" ili "http://10.4.0.6" podigao bilo sta.
    Ako sa mreznog racunara (koji ima mreznu adresu "10.4.0.3" na primer, sa Netscape browsera otkucam "http://10.4.0.6" otvara se prva strana na XP racunaru, "webpay.HTM", znaci IIS radi.

    Sada je samo stvar access rights i grupnih podesavanja ili sharinga.

Pravila za slanje poruka

  • Ne možete kreirati novu temu
  • Ne možete poslati odgovor
  • Ne možete dodati priloge
  • Ne možete prepraviti svoju poruku
  •